PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

pgdbg fails on Mac OS X
Goto page Previous  1, 2, 3, 4, 5
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
Wich



Joined: 15 Dec 2012
Posts: 1

PostPosted: Wed Jan 09, 2013 3:05 pm    Post subject: Reply with quote

Hello!
Recently I downloaded a trial version of the compiler for evaluation purposes and had problems making the debugger work in mountain lion even after checking/following all the things mentioned in this thread. The only way that I managed to make the debugger work is by launching it with sudo: I didn' t test it a lot as I was more interested in the GPU stuff and had limited time but it seemed to at least work(aside from some messages from the debugger itself)...obviously this is not an optimal solution but in the meantime that a proper solution is found you can try it...
Cheers!
Back to top
View user's profile
donb



Joined: 20 Jul 2004
Posts: 88
Location: The Portland Group, Inc.

PostPosted: Wed Jan 09, 2013 5:10 pm    Post subject: Troubleshooting PGDBG on OS X (e.g. task_for_pid failure) Reply with quote

This posting provides a summary of how to troubleshoot problems running PGDBG on Mac OS X. This applies to PGI 12.x and before. We are actively working on addressing the task_for_pid issues for PGI 2013, but it is not clear at this time when a fix will be available.

I. Troubleshooting task_for_pid failures:
    (1) make sure that the PGI software is installed on a local drive (not a network drive)
    (2) make sure that the pgdebug, pgserv, and pgsampt executables have setgid 'procmod' permissions
    Code:
    -rwxrwsr-x  1 root  procmod  23031904 Oct 19 16:35 pgdebug
    -rwxrwsr-x  1 root  procmod   1715760 Oct 19 16:35 pgsampt
    -rwxrwsr-x  1 root  procmod    135816 Oct 19 16:35 pgserv

    (3) make sure that the debugger user is a member of the Unix group 'procmod'
    Code:
    $ id
    uid=1010(myuser) gid=1004(users) groups=1004(users),9(procmod)

    (4) make sure that the taskgated(8) daemon is configured to use the '-p' option in /System/Library/LaunchDaemons/com.apple.taskgated.plist. Find the 'ProgramArguments' section and make sure that '-p' is listed as shown below.
    Code:
            <key>ProgramArguments</key>
            <array>
                    <string>/usr/libexec/taskgated</string>
                    <string>-p</string>
                    <string>-s</string>
            </array>

II. Troubleshooting dynamic library issues
    PGDBG does not currently support debugging dynamic libraries on Mac OS X

III. Troubleshooting CANNOT LOAD errors:
    (1) make sure that the main executable of the program has been built with ASLR disabled
      * this is the default when using the PGI compiler driver with '-g' to link
      * if not using the PGI compiler driver to link, link with '-no_pie'
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3, 4, 5
Page 5 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group