PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Out of memory
Goto page 1, 2  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming
View previous topic :: View next topic  
Author Message
jand



Joined: 17 Aug 2008
Posts: 57

PostPosted: Thu Sep 13, 2012 1:25 pm    Post subject: Out of memory Reply with quote

Hi,

I just started testing a laptop with (GT 650M card in a macbook pro). A fairly simple code that I often use to test a new computer does not run properly and exitst with
Code:

0: ALLOCATE: 19920 bytes requested; status = 2(out of memory)


Any idea why this would happen? Surely, there would be enough global memory (the card has 1 GB). The shared and constant memory appears to be the same as on other cards I use.

Any hints would be great.
Thanks, Jan
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6129
Location: The Portland Group Inc.

PostPosted: Thu Sep 13, 2012 1:43 pm    Post subject: Reply with quote

Hi Jan,

How long does the program run? I could be that the OS is killing your GPU program. This generally occurs when running on a system where the GPU is running a display and the OS limits the amount of time a GPU program can run.

- Mat
Back to top
View user's profile
jand



Joined: 17 Aug 2008
Posts: 57

PostPosted: Thu Sep 13, 2012 1:52 pm    Post subject: Reply with quote

Hi Mat,

The crash immediately occurs when the code reaches the first ALLOCATE for device memory and crashes right there. I am guessing it's less than microseconds. I have had code crash before when a Kernel takes a very long time but it's usually several seconds.

The array I am trying to allocate is only 83x60 elements.

Jan
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6129
Location: The Portland Group Inc.

PostPosted: Thu Sep 13, 2012 2:12 pm    Post subject: Reply with quote

I guess I don't know then. Can you send in the code and let me give it a try?

- Mat
Back to top
View user's profile
jand



Joined: 17 Aug 2008
Posts: 57

PostPosted: Thu Sep 13, 2012 2:30 pm    Post subject: Reply with quote

Yes, I can send the code. to trs@...?

Thanks, Jan
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming All times are GMT - 7 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group