PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Unable to use pgcollect
Goto page 1, 2  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
Sriram Chivukula



Joined: 14 Jun 2012
Posts: 5

PostPosted: Thu Jun 14, 2012 2:03 pm    Post subject: Unable to use pgcollect Reply with quote

I trying to profile on of the Fortran application i'm working. I use OpenMP with it.

when i use
pgcollect -allcache <myprog> <myprog arg1> <myprog arg2>

i get this message
pgcollect-Fatal-Unable to find executable pgcollect in path

I run this command from the directory where the executable is present.

I couldn't get solution to this online .
Back to top
View user's profile
Sriram Chivukula



Joined: 14 Jun 2012
Posts: 5

PostPosted: Thu Jun 14, 2012 2:16 pm    Post subject: Reply with quote

I compiled and linked my code with -Minfo=ccff option.

when i use pgcollect <myprog> <myprog args> it works but the pgprof only gives the time based profiling. I want to get the cache misses. For this I found that oprofile has to be running.

I tried to configure it by opcontrol --no-vmlinux(as the machine is running centos 5.8 i dont have the vmlinux but vmlinuz which its not accepting.) then opcontrol --start but even then i'm not able to get any even based profiling.
Back to top
View user's profile
donb



Joined: 20 Jul 2004
Posts: 88
Location: The Portland Group, Inc.

PostPosted: Thu Jun 14, 2012 2:37 pm    Post subject: Reply with quote

The error message looks incorrect: it is coming from pgcollect, so there is no need to find pgcollect on the path. However with just a few quick tests I was unable to reproduce the behavior you are seeing. We want to get you up and running and we want to fix any bug that you have uncovered.

There are a few things to check:

(1) Are you using 64-bit pgcollect for a 64-bit application, or 32-bit pgcollect for a 32-bit application? Set the PATH to your PGI software to change this.

(2) Is your executable "myprog" accessible and on your PATH? Do you need to refer to it as "./myprog"?

(3) Are "opcontrol" and "opreport" on your PATH?

(4) Is the program "pgoprun" on your PATH?

Let us know if any of this helps, so we can either dive deeper into the problem or fix it so you don't run into it again in six months.

thanks
--Don
Back to top
View user's profile
Sriram Chivukula



Joined: 14 Jun 2012
Posts: 5

PostPosted: Fri Jun 15, 2012 6:47 am    Post subject: Reply with quote

Hi Don,
Thanks for you prompt reply. I'm using 64 bit versions (both pgi and application)
I have all of the above in the PATH. I think i was executing the command in a wrong way.
I used this now
pgcollect -allcache ./myprog [myprog args]
Now i get this message.
Couldn't allocate hardware counters for the selected events.
pgprof: could not set oprofile event profiling mode


is it because, i used opcontrol --no-vmlinux
Since the machine has Centos 5.8 i dont have vmlinux but vmlinuz and when i use
sudo opcontrol --vmlinux=/boot/vmlinuz-2.6.18-238.19.1.el5

i get this message.
The specified file /boot/vmlinuz-2.6.18-238.19.1.el5 does not seem to be valid
Make sure you are using the non-compressed image file (e.g. vmlinux not vmlinuz)

Any suggestions ?

Thanks in advance.
Back to top
View user's profile
Sriram Chivukula



Joined: 14 Jun 2012
Posts: 5

PostPosted: Mon Jun 18, 2012 11:46 am    Post subject: Reply with quote

Hi Don,
I could get the vmlinux and configured the oprofile with opcontrol --vmlinux option and
when i use
pgcollect -allcache ./myprog [myprog arguments]

i still get this message :
Couldn't allocate hardware counters for the selected events.
pgprof: could not set oprofile event profiling mode


Am I doing any thing wrong here.

Sriram

Sriram Chivukula wrote:
Hi Don,
Thanks for you prompt reply. I'm using 64 bit versions (both pgi and application)
I have all of the above in the PATH. I think i was executing the command in a wrong way.
I used this now
pgcollect -allcache ./myprog [myprog args]
Now i get this message.
Couldn't allocate hardware counters for the selected events.
pgprof: could not set oprofile event profiling mode


is it because, i used opcontrol --no-vmlinux
Since the machine has Centos 5.8 i dont have vmlinux but vmlinuz and when i use
sudo opcontrol --vmlinux=/boot/vmlinuz-2.6.18-238.19.1.el5

i get this message.
The specified file /boot/vmlinuz-2.6.18-238.19.1.el5 does not seem to be valid
Make sure you are using the non-compressed image file (e.g. vmlinux not vmlinuz)

Any suggestions ?

Thanks in advance.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group