PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Error launching the pgdbg
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
mleair



Joined: 19 Jul 2004
Posts: 67
Location: Portland Group

PostPosted: Thu Sep 15, 2005 10:58 pm    Post subject: follow-up to my previous message Reply with quote

Hi,

Just a follow-up to my previous message...you said that libjpgprof.so does exist. What directory does it exist in? /opt/pgi/linux86-64/6.0/lib ?
The libjpgprof.so (for PGPROF 6.0) and libjpgdbg.so (for PGDBG 6.0) should live in $PGI/{linux86 | linux86-64}/6.0/lib (or in your case /opt/pgi/linux86-64/6.0/lib).

-Mark
Back to top
View user's profile
jevans



Joined: 14 Dec 2004
Posts: 13

PostPosted: Fri Sep 16, 2005 6:50 am    Post subject: Reply with quote

This particular case is an application running in serial mode, so it's definitely not a case of a node not having access to the filesystem on which the shared libraries reside. Nonetheless, things weren't quite as I thought. I was trying to solve the gui problem at the same time as trying to solve the text mode problem, and one was getting in the way of the other. Text mode seems to work without any special settings at all. But setting PGI_JAVA seems to prevent text mode from working (hope the output below isn't too muddled).


[jevans@evans-temp srcS]$ PGI_JAVA=/usr/java/jre1.5.0_04/bin/java \
pgprof -text -exe oceanS gmon.out

Exception in thread "main" java.lang.UnsatisfiedLinkError: /opt/pgi/linux86-64/6.0/lib/libjpgprof.so: /opt/pgi/linux86-64/6.0/lib/libjpgprof.so: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.load0(Unknown Source)
at java.lang.System.load(Unknown Source)
at jpgprof.main(Unknown Source)



And setting LD_LIBRARY_PATH in conjunction with PGI_JAVA yields

[jevans@evans-temp srcS]$ LD_LIBRARY_PATH=/opt/pgi/linux86-64/6.0/lib \
PGI_JAVA=/usr/java/jre1.5.0_04/bin/java \
pgprof -text -exe oceanS gmon.out

/usr/java/jre1.5.0_04/bin/java: relocation error: /opt/pgi/linux86-64/6.0/lib/libpthread.so.0: symbol _h_errno, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference


In trying to get gui mode working, various attempts yield


[jevans@evans-temp srcS]$ pgprof -exe oceanS gmon.out
Exception in thread "main" java.lang.UnsatisfiedLinkError: /opt/pgi/linux86-64/6.0/jre/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1586)
blah blah blah

[jevans@evans-temp srcS]$ PGI_JAVA=/usr/java/jre1.5.0_04/bin/java \
pgprof -exe oceanS gmon.out

java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
blah blah blah

Caused by: java.lang.UnsatisfiedLinkError: /opt/pgi/linux86-64/6.0/lib/libjpgprof.so: /opt/pgi/linux86-64/6.0/lib/libjpgprof.so: cannot open sharedobject file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
blah blah blah

[jevans@evans-temp srcS]$ PGI_JAVA=/usr/java/jre1.5.0_04/bin/java \
LD_LIBRARY_PATH=/opt/pgi/linux86-64/6.0/lib \
pgprof -exe oceanS gmon.out

/usr/java/jre1.5.0_04/bin/java: relocation error: /opt/pgi/linux86-64/6.0/lib/libpthread.so.0: symbol _h_errno, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference
Back to top
View user's profile
mleair



Joined: 19 Jul 2004
Posts: 67
Location: Portland Group

PostPosted: Fri Sep 16, 2005 12:42 pm    Post subject: pgprof problems Reply with quote

Hi,

I can say that the relocation errors that you are getting when you set LD_LIBRARY_PATH is probably due the lack of ":$LD_LIBRARY_PATH" at the end of "LD_LIBRARY_PATH=". There's probably other things in your LD_LIBRARY_PATH that are getting dropped when all you enter is "LD_LIBRARY_PATH=/opt/pgi/linux86-64/6.0/lib". Also please add the "export" keyword in front of "PGI_JAVA=" and "LD_LIBRARY_PATH=" if you are using bash or sh for your shell. If you are using csh or tcsh, then add "setenv" in front of these (see below).

So, in summary try the following:

If you are using bash or sh for your shell:

export LD_LIBRARY_PATH=/opt/pgi/linux86-64/6.0/lib:$LD_LIBRARY_PATH

export PGI_JAVA=/usr/java/jre1.5.0_04/bin/java

If the above works, try it without the LD_LIBRARY_PATH line.


If you are using csh or tcsh as your shell, enter the following instead:

setenv LD_LIBRARY_PATH /opt/pgi/linux86-64/6.0/lib:$LD_LIBRARY_PATH
setenv PGI_JAVA /usr/java/jre1.5.0_04/bin/java

-Mark
Back to top
View user's profile
jevans



Joined: 14 Dec 2004
Posts: 13

PostPosted: Mon Sep 19, 2005 2:20 pm    Post subject: Reply with quote

Sorry for not being clear, I had put continuation characters on the commands, so it's the same effect as, say for example, passing environment variables into a configure command. My LD_LIBRARY_PATH variable is never set to anything anyway. Before posting, I'd actually been performing the same function as LD_LIBRARY_PATH with /etc/ld.so.conf, and was getting the same results, as well as when explicitly exporting the setting for PGI_JAVA.
Back to top
View user's profile
mleair



Joined: 19 Jul 2004
Posts: 67
Location: Portland Group

PostPosted: Mon Sep 19, 2005 4:51 pm    Post subject: pgprof problems Reply with quote

jevans wrote:

[jevans@evans-temp srcS]$ LD_LIBRARY_PATH=/opt/pgi/linux86-64/6.0/lib \
PGI_JAVA=/usr/java/jre1.5.0_04/bin/java \
pgprof -text -exe oceanS gmon.out

/usr/java/jre1.5.0_04/bin/java: relocation error: /opt/pgi/linux86-64/6.0/lib/libpthread.so.0: symbol _h_errno, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference



[jevans@evans-temp srcS]$ PGI_JAVA=/usr/java/jre1.5.0_04/bin/java \
LD_LIBRARY_PATH=/opt/pgi/linux86-64/6.0/lib \
pgprof -exe oceanS gmon.out

/usr/java/jre1.5.0_04/bin/java: relocation error: /opt/pgi/linux86-64/6.0/lib/libpthread.so.0: symbol _h_errno, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference


Hi,

I talked with another engineer here and it turns out we have seen this error before, but in another context. In addition to setting PGI_JAVA and LD_LIBRARY_PATH, try setting the following:

(bash/sh)
export LD_ASSUME_KERNEL=2.2.5

or

(csh/tcsh)
setenv LD_ASSUME_KERNEL 2.2.5

Also, what version of JAVA 1.5 did you install? Was it just the regular linux (32-bit) version? Or did you install the AMD-64 Opteron version of java 1.5? You'll want to be using the 32-bit (regular linux) version of the Java JRE for PGPROF (and PGDBG).

If the LD_ASSUME_KERNEL=2.2.5 does not help and you are using the 32-bit version of java on linux, then verify that the file that the softlink /opt/pgi/linux86-64/6.0/lib/libpgthread.so links to exists on your system. We do find it a bit peculiar that java is looking for libpthread.so.0 in the PGI directory. There is a softlink called libpgthread.so that links to it, so maybe it's looking there because there is no libpthread.so.0 on the system?


-Mark
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group