PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Problem installing trial PVF on Windows7

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
litldebe



Joined: 02 Aug 2011
Posts: 3

PostPosted: Thu Aug 04, 2011 8:30 am    Post subject: Problem installing trial PVF on Windows7 Reply with quote

I've tried installing both the version with Visual Studio and without. Each time I get a few error messages during installation, and when I try to start VS, I go straight to the file manager.
The errors I've recorded are:
RegDBGetKeyValueEx(%s,%s): Value not found
Software\Wow6432Node\Microsoft\VisualStudio\10.0\Setup\VS

"One of the final steps failed during the configuration of Microsoft Visual Studio:
(code 2).
This problem can be resolved after installation completes by running the following command in a PGI Command Prompt window:
CMD>"devenv.exe /setup"

The template installation step failed during the configuration of Microsoft Visual Studio:
(code 2).
This problem can be resulved after installation completes by running the following command in a PGI Command Prompt window:
CMD>"devenv.exe /installvstemplates"
Back to top
View user's profile
ams



Joined: 14 Jul 2004
Posts: 41

PostPosted: Thu Aug 04, 2011 4:33 pm    Post subject: Reply with quote

It sounds as though the install package thinks VS is already installed on your system but it obviously isn't there or PVF would work.

Did you install any other version of VS prior to trying to install PVF? For example, VS Express or any other VS trial version?

Take a look at what's installed using your system's Programs and Features as well. The install package determines the presence of VS based on a registry key and if that key hasn't been removed by whatever installation(s) put it there, then PVF won't install correctly.
Back to top
View user's profile
litldebe



Joined: 02 Aug 2011
Posts: 3

PostPosted: Fri Aug 05, 2011 7:23 am    Post subject: VS presence Reply with quote

Yes, I have VS 2010 Express installed. I also have a trial version of VS from the Intel Visual Fortran and I have a folder for VS 2008.
Back to top
View user's profile
ams



Joined: 14 Jul 2004
Posts: 41

PostPosted: Fri Aug 05, 2011 7:51 am    Post subject: Reply with quote

PVF cannot be installed with VS Express. You will need to uninstall the PVF components, then uninstall all of the components that installed with VS Express, before attempting to install PVF again.

PVF should successfully co-install with an installation of Intel Visual Fortran.

The installations of VS 2008 and VS 2010 are completely separate so the presence of VS 2008 should have no bearing on the current installation issues.
Back to top
View user's profile
litldebe



Joined: 02 Aug 2011
Posts: 3

PostPosted: Fri Aug 05, 2011 8:36 am    Post subject: VS 2010 Reply with quote

I was able to load PGI Visual Fortran after removing VS 2010. Thanks for the help.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group