A security flaw was recently identified in the FlexNet software PGI uses to license manage its products. The flaw is present in license manager utilities prior to FlexNet version 11.13.1.2. More information is available on the NIST website.

To address this issue, PGI has released new FlexNet daemons.

The following FAQ addresses what you as a PGI user should do.


Which PGI versions are affected?

All PGI releases prior to 2016 version 16.4 have license utilities that should be replaced with FlexNet 11.13.1.3 or newer utilitities included in all PGI download packages beginning with version 16.4.


As a PGI users, what do I need to do?

We recommend you shutdown any currently running license services and replace (see below) the FlexNet utlities with version 11.13.1.3 or newer. After installing the updated utilitiies, restart your license service by entering lmgrd.rc start. (Windows and OS X users, please refer your respective sections in the PGI Installation Guide for information on stopping and restarting your license services.) Once the license service is restarted, any client using the license service should benefit from the update. You can verify which version is running by following the steps outlined below.


Where can I get new daemons and utilities?

Updated FlexNet utilities are included in all PGI 16.4 or newer download packages. After downloading and installing, you should have access to the new license utilities that address the security patch.

Alternatively, you can download a separate package containing only the license daemons and utilities. First stop your license services as outlined above, then copy the daemon package contents into the bin directory inside your existing PGI installation directory (e.g. $PGI/linux86-64/2016/bin) and restart your services.


How do I determine which lmgrd or pgroupd versions I'm using?

To determine the version of your license service components, enter the following commands at the prompt in a your shell, command or terminal window. You should see output similar to the following:

$  lmgrd –v
lmgrd v11.13.1.3 build 176483 x64_lsb - Copyright (c) 1988-2015 
Flexera Software Inc. All Rights Reserved.

$  pgroupd -v
13:28:48 (pgroupd) FLEXnet Licensing version v11.11.1.3 build 176483 
x64_lsb 


Can I run new pgroupd with older daemons from other vendors?

Yes. They should work as before.


Can I run new pgroupd with older lmgrd versions?

It should work, but the security issues are only addressed when you update both lmgrd and pgroupd.

Click me